October, 2025
Incident Updates
Wednesday, October 8th
No Incidents
Thursday, October 9th
No Incidents
Friday, October 10th
INVESTIGATING
Data and SMS service suspended in Russia
INVESTIGATING
VoIP Termination to Russia suspended
Saturday, October 11th
No Incidents
Sunday, October 12th
No Incidents